Introduction to ESRI ArcMap 10.2

Hands-on Training Manual
for Geospatial Analysis using ArcGIS 10.2

Compiled by Stefanie Bohms¹, MacKenzie Friedrichs¹
and Claudia Young²

edited by Stephen Palka²

¹Stinger Ghafferian Technologies (SGT) Inc.
²Innovate Inc.

Sioux Falls, SD
October 15th, 2014
In this Hands-on training exercise you will be introduced to the Environmental Systems Research Institutes (Esri) ArcMap 10.2 software and advance your experience with different data sets and GIS tools.

The workshop is split into 3 sections. The first section familiarizes you with the ArcMap software, the interface, and the toolbars that are available. The second section introduces you to some of the tools that are available in ArcMap and teaches you how to use them. The third section is a critical thinking exercise where you will be applying some of the skills you have learned to solve a problem.

After finishing these exercises you will have a basic understanding of the capabilities of GIS software. You will be amazed at the ease with which you can take advantage of ArcGIS to successfully create maps and analyze different data types.
Chapter 1 – Introduction to ArcMap 10.2

Objective: Get familiarized with the ArcMap 10.2 interface and basic tools

- Start ArcMap 10.2

When you start ArcMap 10.2 for the first time, you will see the following interface.

Click OK to advance to the main interface. The Interface has 4 main sections:

1) Main menu, window menus, toolbars
2) Data frame window
3) Table of Content
4) Windows
- Add a topographic basemap and explore an US state of your choice

To add new data to your data frame click the arrow to the right of the Add Data button and select Add Basemap...

Select the topographic basemap and click Add.
- Navigate to your selected state by using the Tools Toolbar

- Add the South Dakota county shapefile

**Q:** What is a shapefile?

**A:** A shapefile is a simple, nontopological format for storing the geometric location and attribute information of geographic features. Geographic features in a shapefile can be represented by points, lines, or polygons (areas).

(http://resources.arcgis.com/en/help/main/10.2/index.html#/What_is_a_shapefile/005600000002000000/)

To add a shapefile to the map, use the *Add Data* button and browse for the shapefile named South_Dakota.shp in the workshop folder (location provided during workshop).
After the shapefile is added, change the symbology to no fill so you can see the basemap behind to shapefile. Right click on the shapefile name in the Table of Contents and select Properties then click on the ‘Symbology’ tab in the window that opens up.

Left click the colored box under the Symbol section and select Hollow in the Symbol Selector window. Click OK and on the two windows you opened up to take you back to the main interface.

- Inspect the attribute table and label counties with FIPS codes.

To access the Attribute Table, right-click the shapefile in the Table of Contents and select Open Attribute Table. Look around and see what attributes are available. Your table might look slightly different from the one below.
To label each county, close the attribute table, right-click on the shapefile and select *Label Features*. By default, the counties are labeled with their name. To change the label to the county FIPS code, right-click the shapefile and select *Properties*. On the *Labels* tab go to the *Text String* section, select CNTY_FIPS from the drop-down menu, and click *OK*.

Now, we will symbolize each county according to its FIPS code. Right click on the shapefile and select *Properties*. Next, select the Symbology tab, click on *Categories* and then *Unique values*. In the Value Field select CNTY_FIPS. Click the *Add All Values* button and then select the first color ramp from the Color Ramp drop down menu. Click *OK*. Each county now has a unique color.

Note: You have not made any changes to the underlying data, just the way you are viewing it.
You could also symbolize the data using **Graduated symbols** and population information.

On the Symbology tab select Quantities and then *Graduated symbols*. In the Fields box select POP1999. In the classification box select 3 for the number of classes. Change the color of the symbols in the Template box and change the Background to Hollow. Adjust the Symbol Size to 6 and 24. Click OK. The data are now symbolized with circles of increasing size representing the population of each county.

For more information about symbolization techniques go to:
- Save your Map

To save your map select File → Save or Save As... or click on the Save button and save it to a location of your choice on your computer, naming it Chapter1.mxd.
Chapter 2 – Tools in ArcMap 10.2

Objective: Explore raster data and the different popular tools within ArcGIS for spatial analysis

- Add the South_Dakota shapefile and the PRISM2013 raster to ArcMap

Click the Add Data button and browse to the workshop folder. Select the shapefile South_Dakota and click Add. Navigate back to the same location, find the raster PRISM2013.tif and click Add. You will see a black/grey shaded image. You might have to zoom out to the full extent to the file. Right-click on the PRISM2013.tif file in the table of content and click Zoom to Layer. Now you should be able to see the entire extent of the data is the continental US.

Each pixel of this raster represents a 4 km x 4 km area on the ground, and the value in the pixel represents the rainfall amount for that area in mm for 2013.

Q: What is raster data?
A: A raster consists of a matrix of cells (or pixels) organized into rows and columns (or a grid) where each cell contains a value representing information, such as temperature. Rasters are digital aerial photographs, imagery from satellites, digital pictures, or even scanned maps. (http://resources.arcgis.com/en/help/main/10.2/index.html#/What_is_raster_data/009t00000002000000/)

- Clip/ Extract the rainfall raster for South Dakota

Next, you will use the Arc Toolbox. Click on the Arc Toolbox button to open it. There are different toolboxes within the Arc Toolbox that can be used for various geoprocessing tasks. For example, the Data Management Toolbox provides a rich and varied collection of tools that are used to develop, manage, and maintain feature classes, datasets, layers, and raster data structures.

In order to extract a subset of a raster you need the Spatial Analyst extension. To turn it on go to Customize → Extensions, and check the box for Spatial Analyst.

Expand the Spatial Analyst Tools in the ArcToolbox. Further expand the Extraction toolset, and then double click on Extract by Mask.
Select the required data for the inputs as shown in the screenshot above and click OK. The newly created raster will be added to the Table of Contents. For more information on this tool go to: [http://resources.arcgis.com/en/help/main/10.2/index.html#/009z0000002n000000](http://resources.arcgis.com/en/help/main/10.2/index.html#/009z0000002n000000)

- Change the color ramp from black to blue gradient

Left click the color ramp of the new file and select a blue color ramp from the drop down menu. Your map should look very similar to the one below.
- Determine the average amount of rainfall by county and add the values to the South Dakota county shapefile's attribute table

Another toolset in the Spatial Analyst Tools is called Zonal and provides tools to summarize data by zones. Use the **Zonal Statistics as Table** tool to summarize the rainfall by county. Select the following inputs and then click OK.

For more information about this tool go to: http://resources.arcgis.com/en/help/main/10.2/index.html#/009z000000w8000000

The table that you create will be displayed in the Table of Contents. To take a look at the average values, right click on the table name and click **Open**. You see the Names of the counties, the area, and the average values in the last column.

To join the created table with the table of the South Dakota shapefile, right click on the South Dakota shapefile and select **Join and Relates** and then **Join**.

Select the **NAME** field (this is a field that both tables have in common) and then click OK to join the two datasets together. The mean values will now be at the end of the South_Dakota shapefile. You can move the column towards the front by left click on the field name in the attribute table and dragging the column to your desired position.
For more information about joining tables go to:  
http://resources.arcgis.com/en/help/main/10.2/index.html#/005s0000002n00000

You can now map the mean values using the symbology tab in the properties of the South Dakota shapefile.

Right click on the South_Dakota shapefile and select Properties. Navigate to the Symbology tab. Select Quantities and then Graduated colors. Under Fields, select Mean for your Value. Choose a color ramp that you think fits the data and click OK.

Your result should look similar to the graphic below but might differ depending on the color ramp you chose.

![Map of South Dakota with mean rainfall values](image)

This map shows the spatial pattern of the average rainfall by county very clearly. The western part of South Dakota was drier then the eastern part.

- Add raster ‘PRISM2012’ to ArcMap and calculate the difference between the 2 years

Use the Add Data button to browse to the workshop folder. Select the raster PRISM2012.tif and click Add. Repeat the earlier steps to extract the data for South Dakota.

The difference is calculated by using the Minus tool in the Math toolset.

Double click the Minus tool, select the extracted 2013 and 2012 raster files, and then give the output a name, such as PRISM_Diff1312.tif. The output will be displayed in the Table of Content.
To highlight the difference, apply a red-blue color ramp. Since the red is assigned to the high, positive difference, invert the color ramp so red shows the negative difference.

For more information about this tool go to:

- Convert mm of rainfall to inches

This step involves the use of the Raster Calculator which is located in the Spatial Analyst Tools → Map Algebra → Raster Calculator. Double click to open the tool. To perform the calculation, double click the PRISM_Diff1312.tif raster. It will now be available in the box in the middle of the tool. The rest of the equation is displayed below in the next screen shot.
The spatial pattern reveals that the Black Hills received less rain in 2012 (approximately 500-600mm or 20 inches) and the eastern part of South Dakota received less or about the same in both years.

For more information about the 'Raster Calculator' go to: http://resources.arcgis.com/en/help/main/10.2/index.html#//009z000000z7000000

Add and elevation raster to see if elevation has a role in rainfall patterns

Use the add data button to browse to the workshop folder. Select the raster SD_dem_30m_utm.tif and click Add.

Move the elevation raster above the PRISM2013_SD.tif file and visually compare the two by checking and unchecking the box next to the elevation layer. Another way to compare the two rasters is to use the Swipe tool in the Effects toolbar. On the main toolbar select Customize → Toolbars → Effects. In the Effects toolbar first select the file you want to use the effects on. In this case select ‘SD_dem_30m_utm.tif’, and then click the swipe tool.

Click on the raster and hold down the right mouse key to swipe the file back and forth or up and down.
Q: Is there a relation between elevation and rainfall?! Explain what you see in the two rasters.

A:

- **Create Map**

Select View from the main menu and then select Layout View. This changes the data frame from Data View to the Layout View where you can create a map.

- **Add Map Components**

Select Insert from the main menu. Here, you can map elements.

First add a title. Click on Title and a window will pop up. Type “South Dakota Rainfall” and click OK. The text will be added to the map. You can drag this text around and place it anywhere within the page layout space.

Add a north arrow by clicking North Arrow… A window will pop up where you will be able to choose a north arrow. Pick one that you like and click OK. You can drag the north arrow around and also resize it by clicking on the arrow and then dragging one of the four boxes that appear at the corners.

Add a scale bar by clicking Scale Bar… A window will pop up where you will be able to choose a scale bar. Pick a scale bar and click OK. You can move and resize this element just like the north arrow.

Add a legend by clicking Legend… The Legend Wizard window will pop up. On this first window you can add and remove the layers that will appear in you legend under the Legend Items column. Use the arrows in the center of the window to move data sets between the two columns.

Make sure the raster that you converted to inches is the only data set in the Legend Items column. Click OK.

Accept the defaults on the next three windows by clicking Next and then click Finish on the fourth window to create your legend. Like the previous two elements you can move and resize the legend.

- **Save your Map**

To save your map select File → Save or Save As…or click on the Save button. Save it to a location of your choice on your computer and name it Chapter2.mxd. Export Map
To export your map select File → Export Map… You can choose a location to save the file and rename the output if you wish. You can also change the output format under the Save as type: drop down menu.

Select PDF from the drop down. Make sure the Resolution is set to 300 dpi, the Output Image Quality slider is set to Best, and the Ratio is 1:1.

Click Save. You should now have a PDF version of the map created in the previous exercise. This is an easy way to share your work with other who do not have ArcGIS software.
Chapter 3 – Solving a problem using critical thinking

Objective: Solving a real-life problem using geospatial analysis tools in ArcGIS 10.2

For exercise three you are going to perform a site analysis. You are going to try to find the best location for a new arcade in Rapid City. There are many different aspects that can go into a site analysis. For this particular exercise you are going to focus on proximity to existing roads, slope of the surrounding land, land use, and some demographic data. In combining this datasets you will be able to find locations where you could potentially build this new business.

Add data to ArcMap
Click the add data button and navigate to the location (XXX). There are multiple datasets that you will want to add from this location.
- Major_Roads.shp
- Pennington_Land_Use.shp
- AOI.shp
- Pennington_Slope.tif
- Pennington_Block_Group.shp

Extract necessary data from the slope raster
AOI.shp is the area of interest for this exercise. You can use this shapefile to extract the necessary data from the slope raster. The slope raster identifies the slope from each cell in the raster. In this case the values show percent change from one cell to the next. It is important to identify these areas because you will be able to save money by not having to excavate the land.

Use the ‘Extract by Mask’ tool to complete this step.

An easy way to find this tool again is to use the search window on the main toolbar. Click on the button and then type in the name of the tool in the search bar. A list will appear and you can click on the tool name to open it. Look back at previous exercises if you need a refresher on how to complete this step.
**Buffer the roads**

We also want to locate our building near existing roads. This will make it easier to get to.

In the Arc Toolbox navigate to → Analysis Tools → Proximity → Buffer. Choose your road dataset to buffer and enter a distance value that you think fits the problem. Under ‘Dissolve Type’ choose ‘List’ and then select ‘ROADNAME’ from the ‘Dissolve Field’ window. Checking these boxes will merge the buffer polygons together based on name. Click OK.
Create Zonal Statistics Table for the buffers
Since we want to look at the data from the slope raster we are going to create a zonal statistics table. This process will be very similar to that of the previous exercise.

In the Arc Toolbox navigate to Spatial Analyst Tools → Zonal → Zonal Statistics as Table. Use the buffered roads dataset as the input, the ROADNAME field as the zone field, and the AOI slope raster as the Input Value raster. You can choose whether you want to include all of the different statistics options or just a particular one.
Join the table to data
The next step is to create a join between to road buffers and the Zonal statistics table. If you need a refresher on how to do this look back the previous exercises.

You can use the ROADNAME field to create the join between the table and the road buffer shapefile. This will allow you to associate the statistics created in the previous step with the polygons created in the buffer process.
Symbolize data
Symbolizing the data will make it easier to see which areas are best suited for the new building.

Right click on the buffered roads and select Properties and then navigate to the symbology tab. Under Quantities, select Graduated colors and select a value to symbolize along with a color ramp you want to display your data in. You might have to flip your color ramp in order for the colors to match the data. Left click on the ‘Symbol’ column header and choose Flip Symbols if this is necessary.

You can now easily see which areas have roads that lie on flat land.

Further refine your search
You can further refine your search by incorporating the land use data that you added to the map earlier.

Right click on the Land_Use layer and select Open Attribute Table. In the upper left hand corner of this window click on the Options icon and then select ‘Select By Attribute.’ This windows allows you select a subset of the entire dataset.
In the list of Field names find LUCODE and double click on it. It has now been added to the expression window at the bottom of the menu. Now, click on the Equals button to add it to the expression window. Finally, click Get Unique Values and double click 12.

Click Apply and then ‘Close’.
With the polygons you just selected still highlighted, navigate to Selection on the Main Menu and select, ‘Select By Location’. For the Selection Method choose ‘select features from.’ For Targets layers choose the buffered roads. For the Source layer choose the Land_Use dataset. Also, make sure to click the check box next to ‘Use selected features.’ This option will make it so the query will only be run on those areas you selected in the previous step. For ‘Spatial selection method for target layer features’ choose intersect the source layer feature. Click OK.

You have now found which roads lie in commercial areas of the city. In order to save this subset of data you should export it. Right click on the buffered roads layer, navigate to Data and then select Export. Under the Export drop down menu make sure ‘Selected features’ is selected. Choose a location for this data set a click OK. Add the new data set to your map.

If you want to continue to refine your search you can use the block group data that you added to the map earlier. A block group is a geographic unit that the census uses. The populations in a block group ranges from about 600 – 3,000 people. If you look at the attribute table for this dataset you can see that many different statistics are collected on age, race, and households.
For this exercise we also want to look at the ‘AGE_10_14’ field since we are trying to find a location for a new arcade. Symbolize the block group dataset by this field. You will want to select ‘Graduated colors’ under the ‘Quantities’ option in the ‘Symbology’ tab. Pick a color ramp that you think fits this situation. Remember, you might have to flip the symbols depending on which color ramp you choose.

You can now see which block groups have higher numbers of 10 to 14 year olds.

With this information along with your classified roads you can start to get a picture of areas that would be a good choice to locate your arcade. Your finished product might look different depending on the colors you chose to symbolize your data but you can use it as a guide for your own work.

In the example below you would want to pick locations that are near both green road buffers and green block groups. Such locations represent areas that are within 100 ft. of a road, lie on land with a low gradient, and are near block groups with high numbers of teenagers. These areas would be perfect for a new arcade!